Welcome, Guest
Username: Password: Remember me
s =

TOPIC: Suchfunktion CaseInsensitive

Suchfunktion CaseInsensitive 1 month 3 weeks ago #57729

Hallo,

bei meiner Dolibarr 10.0.6 Installation ist die Suche Case-Sensitive. Bei den Online-Demos ist das dagegen nicht der Fall.
Ich habe bisher keine Möglichkeit gefunden, das umzustellen.

Gibt es dafür eine einfache Lösung?
Die Suche mag auch keine Umlaute, damit kann ich aber leben.

Danke!
Andreas
The administrator has disabled public write access.

Suchfunktion CaseInsensitive 1 month 2 weeks ago #57743

  • com4WEB
  • com4WEB's Avatar
  • OFFLINE
  • Senior Boarder
  • ich freu mich über ein Dankeschön
  • Posts: 75
  • Thank you received: 10
  • Karma: 0
Hallo,

das ist eher ungewöhnlich und ich vermute mal, dass es weniger an Dolibarr als an ihrer Systemumgebung liegt.

Können Sie mal schreiben, was sie wie wo installiert haben?
Also z.B. Betriebssystem, Webserver, PHP-Version usw.


Mit besten Grüßen

Udo Tamm

dolibit.de / com4WEB.de
The administrator has disabled public write access.

Suchfunktion CaseInsensitive 1 month 2 weeks ago #57763

Hi,

das läuft unter Ubuntu 18.04 LTS, Locale ist en_US.UTF-8
Webserver ist apache 2.4.29-1ubuntu4.11
php ist libapache2-mod-php7.2

Installiert habe ich nur das dolibar-Package auf dem zip-File, mehr läuft auf dem Server auch nicht.

Angefangen hatte ich angeblich mal mit 8.04, das müsste eine Installation aus einem Paket gewesen sein:
MAIN_VERSION_FIRST_INSTALL 8.0.4 0
MAIN_VERSION_LAST_INSTALL 10.0.2 0
MAIN_VERSION_LAST_UPGRADE 11.0.1

Vielen Dank
Andreas
The administrator has disabled public write access.

Suchfunktion CaseInsensitive 1 month 1 week ago #57774

Ok, jetzt wird es seltsam.

Ich habe eine neue Dolibarr-Instanz erstellt (Ubuntu 18.04, Dolibarr 11.0.1) und nur zwei Partner eingetragen.
Ergebnis -> Suche funktioniert Case-Insensitive

Danach habe ich ein Backup der Datenbank und Dokumente der alten Instanz erstellt und in die neue Instanz eingespielt
Ergebnis -> Suche funktioniert Case-Sensitive!

Irgendwas hat also bei dem Import die Suche verändert.
Ein Test via Kommandozeile hat ergeben, dass die Suche intern tatsächlich case-sensitiv läuft:
MariaDB [dolibarr]> select * from llx_societe where nom like '%CTT%';
+-----
[korrektes Ergebnis]
--+--------------------+------------+---------------+
1 row in set (0.00 sec)

MariaDB [dolibarr]> select * from llx_societe where nom like '%ctt%';
Empty set (0.00 sec)

Ich vermute das hat irgendwas mit den Zeichensätzen zu tun. Leider bin ich da mit meinem Latein/SQL am Ende.

Danke
Andreas
Last Edit: 1 month 1 week ago by aholzhammer.
The administrator has disabled public write access.

Suchfunktion CaseInsensitive 1 month 1 week ago #57776

Nachdem ich mein Testsystem zerkonfiguriert habe, habe ich nochmal eine Instanz streng nach howtoforge installiert:
www.howtoforge.com/tutorial/how-to-insta...-crm-on-ubuntu-1804/
Ergebnis: Suche ist Case-Sensitive!

Die Installation gestern hatte ich nach der Anleitung erstellt:
computingforgeeks.com/install-dolibarr-e...rm-ubuntu-18-04-lts/
Ergebnis gestern: Suche ist Case-Insensitive!

Der Unterschied scheint die Art zu sein, wie die Datenbank angelegt wird:
MariaDB [(none)]> CREATE DATABASE dolibarrdb character set UTF8 collate utf8_bin;
Führt zu Case-Sensitiver Suche
The administrator has disabled public write access.

Suchfunktion CaseInsensitive 1 month 1 week ago #57778

Ich habe jetzt einen Weg gefunden, wie ich die Datenbank von utf8 nach utf8mb4 konvertieren kann. Es sind dafür einige Anpassungen notwendig gewesen.

Einstellung an der Datenbank vornehmen, sonst konnt es zu einem "Index column size to large" Fehler:
stackoverflow.com/questions/42043205/how...te/52778785#52778785
Dazu habe ich eine Datei "/var/mysql/conf.d/dolibarr.cnf angelegt
[server]
innodb_default_row_format=dynamic
innodb_file_format=barracuda
innodb_file_per_table=true
innodb_large_prefix=true

Dann habe ich nach dieser Anleitung die Datenbank konvertiert:
dba.stackexchange.com/questions/8239/how...wertab=votes#tab-top
Ich habe dazu das Script preAlterTables.sql von MrJingles87 genutzt.

Dazu noch vorher laut confluence.atlassian.com/kb/how-to-fix-t...abase-744326173.html die Foreign Key Checks deaktivieren und später wieder aktivieren.

Damit funktioniert die Suche wie gewünscht. Fehler im System konnte ich bisher nicht feststellen. Ich habe aber ein Backup und einen Snapshot in Reserve :-)

Andreas
The administrator has disabled public write access.
Moderators: Peter A. Gebhardt
Time to create page: 0.144 seconds