Welcome, Guest
Username: Password: Remember me
s =

TOPIC: Fehler beim Datenimport

Fehler beim Datenimport 1 month 1 day ago #57085

Hallo an alle,

ich habe folgendes Problem. Ich möchte Kundendaten in Dolibarr importieren. Ich kann auch alle Schritte bis zur Simulation durchführen, auch wird die Excel Datei erkannt. Bei der Simulation erhalte ich dann folgende Fehlermeldung:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log

Kann mir hier jemand weiter helfen? Screenshots der einzelnen Schritte lege ich bei. Kann es sein, dass ich irgendwo noch Schreibrechte vergeben muss? Version ist 9.0.0!

Vielen Dank schon mal!
Last Edit: 1 month 1 day ago by Chris_Meyer.
The administrator has disabled public write access.

Fehler beim Datenimport 1 month 1 day ago #57086

  • ejomi
  • ejomi's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 3
  • Karma: 1
Hallo "Chris_Meyer"!
Das Import-Modul von Dolibarr ist tatsächlich etwas "wackelig" (siehe dazu auch meine "Meckerei" unter Importfehler" und Daten-Referenz).
Nach meinen Erfahrungen ist liegt das Problem beim Import von EXCEL-Dateien in der Tabellen-Formatierung/Text-Gestaltung. Leider sind diese abhängig von der verwendeten EXCEL-Version uneinheitlich - Microsoft sei Dank! Am Besten funktionieren "pure" Tabellen ohne Formate aus älteren EXCEL-Versionen (z.B. EXCEL-2000), eine andere Möglichkeit wäre das Einlesen der Tabellen mit OpenOffice/LibreOffice-CALC und erneutes Abspeichern im EXCEL-Format mit anderem Dateinamen weil OpenOffice diese dann gesäubert abspeichert.
Meine dringende Empfehlung: Nur CSV-Tabellen verwenden - damit gibt es (fast) keine Probleme! Unter EXCEL mit "Speichern unter" und dann "Text mit TABs getrennt". Als Trennzeichen nimmt Dolibarr standardmäßig das Komma, zu empfehlen ist aber das Semikolon weil dieses Satzzeichen relativ selten in Import-Texten vorkommt und damit falsche Feldtrennungen vermieden werden. Das geänderte Trennzeichen muss man natürlich Dolibarr vor dem Import mitteilen!
Noch ein paar wichtige Hinweise zum CSV-Import:
  1. Zahlen: Bei CSV-Tabellen müssen Fließkommazahlen statt dem Dezimal-Komma mit Punkt übergeben werden - gaaanz wichtig!!
  2. Text sollte grundsätzlich in Anführungsstriche eingekapselt sein.
  3. Beim Import muss bei "Schritt 4" das tatsächlich verwendete Trennzeichen und hinter "Beilage" (super übersetzt - gemeint sind Textfelder) ein Anführungszeichen eingetragen sein.
  4. Außerdem ist bei "Schritt 4" die richtige Umverteilung und Zuordnung der Datenfelder absolut essentiell!!
  5. Bei "Schritt 5" muss die Angabe hinter "Importierte Zeilen mit Nr. (von - bis) auf "2" geändert werden, falls Tabelle Spaltenköpfe enthält sonst hagelt es unzählige Fehlermeldungen beim Import!!
... hoffe, ich konnte helfen - viel Erfolg (nach dem 10. Versuch klappt's meistens)!

Gruß: ejomi
The administrator has disabled public write access.
The following user(s) said Thank You: Chris_Meyer

Fehler beim Datenimport 1 month 1 day ago #57087

Hallo Ejomi,

erstmal vielen Dank für deine Hilfe.

Wenn ich eine CSV Datei hochladen will, komm ich gar nicht erst zum vierten Schritt. Hier kann ich die Datei gar nicht speichern und bekomme die Fehlermeldung als .php die du im Screenshot siehst...

Dann wird mir wohl nichts anderes übrig bleiben als es mit open office zu versuchen. So komm ich leider nicht wirklich weiter
Attachments:
Last Edit: 1 month 1 day ago by Chris_Meyer. Reason: Name geändert
The administrator has disabled public write access.

Fehler beim Datenimport 1 month 1 day ago #57088

  • ejomi
  • ejomi's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 3
  • Karma: 1
... sieht schlecht aus - das Problem hatte ich bisher noch nicht! Vielleicht wäre für die Allgemeinheit mal interessant zu wissen, wer Dein Web-Hoster ist. Interpretiert man die Meldung richtig, scheint a) entweder das Datenvolumen deines Web-Space überschritten oder b) der dortige Server ist vorübergehend überlastet (was eigentlich nicht vorkommen darf). Desweiteren kann noch ein generelle Upload-Beschränkung vorliegen (manche Hoster machen das aus Sicherheitsgründen). Prüfe bitte mal die Speicher-Auslastung auf Deinem Web-Space und/oder rufe mal den dortigen Support an, ob eine Upload-Beschränkung existiert. Ansonsten muß ich an dieser Stelle leider passen :-( Gruß: ejomi
The administrator has disabled public write access.
The following user(s) said Thank You: Chris_Meyer

Fehler beim Datenimport 3 weeks 5 days ago #57092

Also mit den Firmen hat es dann mit einer über Open Office erzeugten CSV Datei geklappt. Bei den Ansprechpartnern erhalte ich wieder den selben Fehler. Wobei die Datei mit den Ansprechpartnern gerade einmal halb so groß ist, wie die Firmendatei.

Ich bin bei Strato, ich habe leider nichts gefunden wo ich evtl. einen Time Out einstellen kann. Ich hab nämlich das Gefühl, dass der Server abbricht, wenn es zu lange dauert. Ich hab mal Strato angeschrieben was die meinen, aber noch keine Antwort bekommen.

Wenn es was neues gibt, schreib ich nochmal.
The administrator has disabled public write access.

Fehler beim Datenimport 5 days 11 hours ago #57134

Ich konnte das Problem nun Lösen. In der Importdatei waren zu viele Fehler für das System. Zum Beispiel waren zu viele Firmen mit dem selben Namen drin, die das System nicht zuordnen konnte. Scheinbar ist das System überlastet, wenn in einer großen Datei zu viele Fehler vorhanden sind. Ich habe es dann Stückweise, in meinem Fall immer 1000 Stk. gemacht. Dann wurden mir die Fehler in der Simulation angezeigt, diese konnte ich dann korrigieren und dann importieren.
The administrator has disabled public write access.
Moderators: Peter A. Gebhardt
Time to create page: 0.173 seconds