Welcome, Guest
Username: Password: Remember me
s =

TOPIC: Schaltfächen / Icons

Schaltfächen / Icons 4 months 1 week ago #56609

  • barusa
  • barusa's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Guten Tag,
gibt es Erfahrung im Forum, dass die Schaltflächen auf den Seiten des Programmes NICHT dargestellt werden?

Folgende .Situation:
In Firefox 58.0.2 (Linux) werden die Schaltflächen in der eigenen Installation nicht dargestellt, während sie im Dolibarr-Demoserver dargestellt werden. Mit Chromiuim 65.0 ergibt sich das gleiche Ergebnis. Über einen aktuellen Firefox unter Win 7 ebenfalls dasselbe Ergebnis. Andere Webseiten werden in allen drei Browsern fehlerlos dargestellt.
Bei Zugriff auf die eigene Dolibarr-Installation über eine andere IP-Adresse werden die Schaltflächen unter Win 7 mit aktuellem Firefox dargestellt.

Das Problem trat in Version 6.0.1 und nach dem Upgrade auf 7.0.0 ebenfalls auf.
Es gibt m.E. keine Kombination, zu der es keine Ausnahme der angenommenen Regel gibt. Daher meine Anfrage, ob dahingehend Lösungen bekannt sind.

Anbei je eine Abbildung aus dem eigenen Server und die selbe Seite aus dem Dolibarr-Demoserver.

Barusa
Attachments:
The administrator has disabled public write access.

Schaltfächen / Icons 4 months 1 week ago #56611

  • tiaris
  • tiaris's Avatar
  • OFFLINE
  • Administrateur
  • Posts: 304
  • Thank you received: 44
  • Karma: 8
Hallo,
Das scheint, als ob das Bild nicht vom Browser geladet wird.
Bilder sind in diesem Order :
/theme/common/folder-new.png und /theme/common/view-refresh.png

Können Sie nachsehen ob diese files in dieser Stellung da sind ? und das dieRechte gut stehen ?
Vielleicht fehlen die Files in Ihrer locale installation. Ist Ihre install ein Wamp package ?

Wenn die Files im /theme/common/ Ordner fehlen, einfach die source noc mal herunter laden, (nicht dans wamp paket, sondern die einfache zip file) und die fehlende Files kopieren.
The administrator has disabled public write access.
The following user(s) said Thank You: barusa

Schaltfächen / Icons 4 months 1 week ago #56616

  • barusa
  • barusa's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
@tiaris
danke für den Hinweis mit den Bildern. Das brachte mich auf den Gedanken den Download von Icons/ Bildern mit 'curl' zu testen. Damit wurde klar, dass die Bilder nicht vom Server ausgeliefert wurden.
Eine Netzsuche ergab zwei Richtungen für die Lösung, entweder eine falsche Webserver-Konfiguration oder ein Fehler in der .htaccess-Datei.
Zweites war der Fall. Der Abschnitt 'Hot-Link Protection' war unvollständig. Neben der Angabe der Domain müssen ebenfalls alle Subdomains angegeben werden.
Warum die Bilder im Fall der anderen IP ausgeliefert werden bleibt für mich ein Rätsel.

Beispiel => Abschnitt in der Datei .htacces im Wurzelverzeichnis /var/www
# prevent hot linking
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?domainname.de [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?subdomain1.domainname.de [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?subdomain2.domainname.de [NC]
RewriteRule \.(jpg|jpeg|png|gif)$ - [NC,F,L]
The administrator has disabled public write access.
Moderators: Peter A. Gebhardt
Time to create page: 0.065 seconds